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Glacier velocity is a vital part of glacier monitoring and understanding of the 

glacier system dynamics as well as providing valuable insights into changes in 

climate conditions.

Two methods are commonly used to derive the speed of the ice flow from the 

satellite data: 

1) SAR interferometry; 

2) feature/speckle tracking (optical/SAR data) between consecutive acquisitions. 

In this tutorial we will use the second method applied to Sentinel-1 data.
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Overview
About Glacier Velocity



In this exercise, you will work with SNAP software to calculate glacier velocity in 

Thorthomi Tsho from a pair of Sentinel-1 data. QGIS will also be used to 

visualize the output. 

Data:

● Sentinel-1 GRDH on 01 June 2019: 

S1A_IW_GRDH_1SDV_20190601T120532_20190601T120557_027486_031

9F2_B634.SAFE

● Sentinel-1 GRDH on 13 June 2019: 

S1A_IW_GRDH_1SDV_20190613T120532_20190613T120557_027661_031

F43_196F.SAFE
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Overview
Data and Software
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Bhutan Glacier Lake Breach Flood

• Occurrence Date (UTC): 20 June 

2019

• SA activation Date(UTC): 22 June 

2019

• Requester: Ministry of Home and 

Cultural Affairs - Bhutan (MOHCA)

National Center for Hydrology and 

Meterology (NCHM)

Overview
Sentinel Asia activation in Bhutan



https://step.esa.int/main/download/

snap-download/

• The Sentinel Application Platform -

or SNAP - in short is a collection of 

executable tools and Application 

Programming Interfaces (APIs) 

which have been developed to 

facilitate the utilisation, viewing and 

processing of a variety of remotely 

sensed data.

• Download the latest SNAP 

software from ESA. SNAP 

supports installers for Windows 64-

bit, Mac OS X, and Linux 64-bit. 

Note: We’ve downloaded the 

installer for Windows 64-bit in the 

training folder.

• Install the software. Use the default 

configuration. 

• Once the installation is finished, 

update all suggested plugins.

Overview
SNAP software

https://step.esa.int/main/download/snap-download/
https://step.esa.int/main/download/snap-download/


1. Main Menu

2. Tool Bars

3. Product Explorer

4. Image View

5. Other windows: Navigation, Color 

Manipulation, World View, etc.
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Data Preparation
Open SNAP software



1. In the Main Menu, go to 

File → Open Product…
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2. Browse to the location of the data. Then select both files of Sentinel-1 data. Each 

file refers to a different acquisition date.

3. Click Open
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Data Preparation
Open Sentinel-1 Data



1. Click Open Product         and navigate to the data folder. Open both Sentinel-1 data.

2. The opened products will appear in the Product Explorer window. Click > to expand the contents of the product [1], 

then expand the Bands folder and double-click on the Intensity_VV band to visualize it. 

Data Preparation
Explore the Sentinel-1 Data
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We will use the Batch Processing tool available in SNAP to apply all steps to both images in one go (this also 

saves disk space as only the final product is physically saved).

1. In the Main Menu, go to 

Tools → GraphBuilder
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2. The Graph Builder window 

will show up. 

In the beginning, the graph has 

only two operators: Read (to 

read the input) and Write (to 

write the output). We will create 

a step-by-step workflow to apply 

identical pre-processing steps to 

both of our scenes.

Data Pre-processing
Open Graph Builder



• The orbit state vectors provided in the metadata of a SAR product are 

generally not accurate and can be refined with the precise orbit files which 

are available days-to-weeks after the generation of the product. 

• The orbit file provides accurate satellite position and velocity information. 

Based on this information, the orbit state vectors in the abstract metadata 

of the product are updated. 

Data Pre-processing
Update the orbit metadata 



3. To add the operator right-click the 

white space between the existing 

operators and go to Add → 

Radar → Apply-Orbit-File
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4. A new operator 

rectangle appeared in 

our graph.

5. Now connect the new  

Apply-Orbit-File

operator with the 

Read operator by 

clicking to the right 

side of the Read 

operator and dragging 

the red arrow towards 

the Apply-Orbit-File

operator. 

6. Notice that a new tab 

also appeared below 

the graph.
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Data Pre-processing
Update the orbit metadata 



• Thermal noise in SAR imagery is the background energy that is generated 

by the receiver itself. 

• It skews the radar reflectivity to towards higher values and hampers the 

precision of radar reflectivity estimates. 

• Level-1 products provide a noise LUT for each measurement dataset, 

provided in linear power, which can be used to remove the noise from the 

product.

Data Pre-processing
Remove the thermal noise 



7. Right-clicking the white space somewhere 

and go to to Add → Radar → Radiometric 

→ ThermalNoiseRemoval
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8. A new operator rectangle 

appeared in our graph.

9. Connect the new operator 

with the Apply-Orbit-File

operator.
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Data Pre-processing
Remove the thermal noise



• Typical SAR data processing, which produces level-1 images, does not 

include radiometric corrections and significant radiometric bias remains. 

• The radiometric correction is necessary for the pixel values to truly 

represent the radar backscatter of the reflecting surface and therefore for 

comparison of SAR images acquired with different sensors or acquired 

from the same sensor but at different times, in different modes, or 

processed by different processors.

Data Pre-processing
Calibration



10.Right-clicking the white space somewhere 

and go to Add → Radar → Radiometric → 

Calibration

11.A new operator rectangle 

appeared in our graph.

12.Connect the new operator 

with both the 

ThermalNoiseRemoval

and Write operators.

13.Save the workflow to 

S1_Preprocessing.xml

14.Close the Graph Builder 

window.
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Data Pre-processing
Calibration



1. In the Product 

Explorer window, 

select (highlight) the 

product [1] (1 June 

2019). Open the 

Batch Processing 

tool (Tools → Batch 

Processing).
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2. We will add both opened products by clicking Add Opened in the 

upper right (the second icon from the top) and then clicking Refresh

(the second icon from the bottom). 
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Data Pre-processing
Batch processing 



3. In the Batch Processing

window, click File → Load Graph

and navigate to our saved graph 

(S1_Preprocessing.xml) and 

open it.

4. We see that new tabs have appeared at the top of the 

Batch Processing window corresponding to our 

operators. We will change the parameter of each 

operator in the next steps.
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Data Pre-processing
Batch processing



6. In the ThermalNoiseRemoval tab select VV

polarization and make sure that the “Remove 

Thermal Noise” option is selected.

5. In the Apply-Orbit-File tab, accept the default 

settings.
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Data Pre-processing
Batch processing



7. In the Calibration tab, accept all default settings.

8. In the Write tab, define your output directory.

9. Click Run. It will take a few seconds or minutes to complete the process. 

You should have 2 new products in the Product Explorer window. Close the Batch Processing window.
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Data Pre-processing
Batch processing



1. In the Main Menu, go to 

Tools → GraphBuilder

2. First, we need to delete the Write operator. Right click on it and select “Delete”. Then 

we need to add a second Read operator. Right-click in the white space and go to Add 

→ Input-Output → Read.

3. We will add the DEM-Assisted Coregistration operator by going to Add → Radar → 

Coregistration → DEM-Assisted-Coregistration and connect both Read operators to it.

4. Next, we will add the Subset operator (Add → Raster → Geometric → Subset) and 

connect the DEM-Assisted-Coregistration operator to it. 

5. Since we want to continue to Offset Tracking and save this subset separately as well, 

we will add the Offset-Tracking operator (Add → Radar → SAR Applications → 

Offset-Tracking) and the Write operator (Add → Input-Output → Write). Connect the 

Subset operator to both Offset-Tracking and Write operator.

6. Lastly, we will add another Write operator (Add → Input-Output → Write) and connect 

the Offset-Tracking operator to it in order to save the final product
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Data Processing
Open Graph Builder: Coregistration and Offset Tracking



7. First, let’s go to the first Read tab and make sure that the pre-processed product [3] from 1-Jun 

2019 is selected as the Source product. Then go to the Read(2) tab and set the pre-processed 

product [4] from 13 Jun  2019 as the Source product.

Data Processing
Read Data
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• Image coregistration is the process of geometrically aligning two or more 

images so that corresponding pixels represent identical area on earth 

surface. 

• It is possible to coregister two or more products using only orbit state 

vectors, however for the purpose of offset tracking we need more precise 

coregistration. 

• Therefore, we use additional information provided by digital elevation 

model (DEM).

Data Processing
DEM-assisted coregistration



8. Go to the DEM-Assisted-Coregistration tab and set “Digital Elevation Model”: SRTM 3Sec (Auto 

Download)

Data Processing
DEM-assisted coregistration
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Since our Area of Interest (AOI) is quite small and there is no need to process the whole image, we start with sub-setting 

the scene to a more manageable size. This will reduce the processing time in further steps and is recommended when 

the analysis is focused only on a specific area and not on the complete scene. 

9. Go to the Subset tab and at “Pixel Coordinates” set:

X         = 19200 Y         = 11000

Width  = 700 Height  = 600
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Data Processing
Subset image



• Offset Tracking is used to estimate the motion of a feature between two 

acquisitions through cross-correlation on selected Ground Control Point 

(GCP) in coregistered images (master and slave) in both slant-range and 

azimuth direction. 

• The movement velocity is then computed based on the offsets estimated 

by the cross-correlation.

• The velocities computed on the GCP grid are interpolated to create 

velocity map. It is a method frequently used for glacier motion estimation.

Data Processing
Offset tracking



The Offset Tracking is performed in the following sub-steps (ESA Snap):

• For each point in the user-specified GCP grid in the master image, compute the corresponding 

pixel position in slave image using normalized cross-correlation.

• If the computed offset between master and slave GCP positions exceeds the maximum offset 

(computed from user-specified maximum velocity), then the GCP point is marked as outlier.

• Perform local average for the offset on valid GCP points.

• Fill holes caused by the outliers. The offset at the missing point will be replaced by a new offset 

computed by local weighted average.

• Compute the velocities for all points on the GCP grid from their offsets.

• Finally, compute velocities for all pixels in the master image from the velocities on GCP grid by 

interpolation (the final product has same pixel size as the input data).

Data Processing
Offset tracking



10. In the Offset-Tracking tab, we need to set several parameters. First, we need to set the GCP grid spacing in pixels 

in range and azimuth directions (determines the resolution/level of detail of our velocity product).

Grid Azimuth Spacing (in pixels): 20

Grid Range Spacing (in pixels): 20

11.Next, we need to set the Registration Window dimensions; the size of the registration window depends on the 

maximum velocity of the glacier (from the literature of historical data) and the period between the data acquisitions.

Max Velocity (m/day): 2.0
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Data Processing
Offset tracking
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12. In both the Write and Write(2) tabs, define your output directory.

Data Processing
Write output
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13.Now that all settings are completed. Run the 

Graph Builder.

Data Processing
Run the Graph Builder

Note:

Depending on the version of SNAP that you have, 

there might be a recurring bug that prevents the 

Graph Builder from running. In such a case, we’ve 

prepared a Graph_offsetTracking_backup.xml file as 

a workaround.

You must load the .xml file in the Graph Builder and 

continue to work from there. You may still have to 

add some operators and modify the parameters as 

necessary.
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Data Processing
Visualize output: velocity



1. Right-click product [5] and open BandMath dialog. 

2. Set “Name” to Sigma0_VV_01Jun2019 

3. Deselect the Virtual (save expression only, don’t 

store data) option because we want to store the 

data.

4. Click on the Edit Expression. 

5. Set Product to: [6]. 

6. In Data Sources, click on 

$6.Sigma0_VV_mst_01Jun2019 band.

7. Click OK in both windows. Repeat the process 

to add also the second band.
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Data Processing
Stack the products



Data Processing
Stack the products (output)



1. Click Radar → Geometric → 

Terrain Correction → Range-

Doppler Terrain Correction

2. In the I/O Parameters tab set as 

“Source Product” the product [5]

(velocity product). Keep the 

default. 3. In the Processing Parameters tab 

set: Click on Map Projection.
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Data Processing
Terrain correction

7



4. In the Map Projection, choose 

Predefined CRS and click on “Select”. 

5. In “Filter” search for 32645 (EPSG: 

32645 – WGS84 / UTM Zone 45N)

6. Click OK to both windows.

7. Click Run in Range Dopler Terrain 

Correction window.
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Data Processing
Terrain correction

5



1. Open the Sigma0_VV_01Jun2019 band in the View window. 

2. To improve the visual, we can modify the histogram. In Colour Manipulation 

tab, select Sliders, then move the slider to the left).

Data Processing
Visualize output: color manipulation
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1. Go to the Layer Manager in the top right corner.

2. Click on       to add an overlay layer.

3. Select Image of Band / Tie-Point Grid.

4. Click Next.

5. Select the Velocity_slv1_13Jun2019_VH.

6. Click Finish.
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Data Processing
Visualize output: overlaying
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Data Processing
Visualize output: overlaying



Data Processing
Visualize output: table of velocity (vector data)

The vector data of velocity 

contains the following information: 

• coordinates of GCP point in 

the master image (1 June) 

and slave image (13 June),

• the distance travelled,

• velocity in m/day, heading in 

degrees (East from North),

• range shift and azimuth shift.

1. Expand the “Vector Data” 

folder of the product [7] and 

double-click on Velocity.
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Data Visualization in QGIS
Open .csv file

1. Open QGIS Desktop software 

2. In the Menu Bar, click on Layer → Add Layer → Add 
Delimited Text Layer.

3. In Data Source, click on the Browse button and 
navigate to the vector file 
...\Subset_S1A_IW_GRDH_1SDV_20190601T120532_20
190601T120557_027486_0319F2_B634_Orb_NR_Cal_St
ack_Vel_TC.data\vector_data\Velocity.csv in the data 
folder.

4. In File format, select Custom delimiter, checklist Tab, and 
uncheck all other delimiters.

5. In Record and Field options, set the Number of header 
lines to discard to “3” and make sure to checklist the “First 
record has field names” option. 

6. In the Geometry definition, select “Well known text (WKT)” 
and set the Geometry type to “Point”. 

7. With this file selected, click Add, then Close. The data you 
specified will now load.
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Data Visualization in QGIS
Convert .csv file to shapefile

1. Right-click on the opened Velocity layer, 

then click Save Vector Layer as

2. In Format, select ESRI Shapefile.

3. Save the Vectorized result to 

Velocity_Point.shp

4. In CRS, make sure to select EPSG: 

32645 – WGS84 / UTM Zone 45N.

5. Click OK.
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Data Visualization in QGIS
Open velocity raster data

1. In the Menu Bar, click on Layer → Add 

Layer → Add Raster Layer.

2. In Data Source, click on the Browse

button and navigate to the file 

\Subset_S1A_IW_GRDH_1SDV_20190

601T120532_20190601T120557_0274

86_0319F2_B634_Orb_NR_Cal_Stack_

Vel_TC.data\Velocity_slv1_13Jun2019_

VH.img in the data folder.

3. With this file selected, click Add, then 

Close. The data you specified will now 

load.
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Data Visualization in QGIS
Change the appearance of the velocity raster layer

1. Right-click on the opened 
Velocity_slv1_13Jun2019_VH raster layer, 
then click Properties.

2. In Render type, change to Singleband
pseudocolor.

3. Let’s change the Min value to 0.2.

4. Right-click the Color for the Min value, 
then select Change Opacity...

5. To make it transparent, change the color 
opacity to 0.

6. Click OK
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Data Visualization in QGIS
Install a plugin: Vector field layer manager

To visualize the velocity vector fields, we 

need to install the Vector field layer 

manager plug-in. 

1. In the Menu Bar, click on Plugins → 
Manage and Install Plugins.

2. In the dialog that opens, find the Vector 
field layer manager plugin.

3. Click Install Plugin.

4. Click Close.

Your new plugin       is installed.
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Data Visualization in QGIS
Setup the velocity vector field

1. In Layer List, select Velocity_Point layer to activate 
the Vector field layer manager plugin.

2. In Toolbar, click 

3. In the Vector field, select Polar (length, angle) field.

4. In the Length attribute, select velocity_D.

5. In the Angle attribute, select Heading_Do.

6. In the Angle units, change to Degrees.

7. In the Arrow format, set the following

• Head: 2.00
• Shaft: 0.20
• Relative head length: 1.00
• Max relative head size: 0.20

8. In the Base size, set to 0.20

9. In the Vector scale, set to 8.0

10.Click Apply.
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Data Visualization in QGIS
Install a plugin: Vector field layer manager



Sources

• Serco Italia SPA (2018). Glacier Velocity with Sentinel-1– Peterman Glacier, Greenland 

(version 1.2). Retrieved from RUS Lectures.

• How to Create Glacier Velocity Maps with Sentinel-1 Toolbox: https://asf.alaska.edu/how-

to/data-recipes/how-to-create-glacier-velocity-maps-with-sentinel-1-toolbox/

https://asf.alaska.edu/how-to/data-recipes/how-to-create-glacier-velocity-maps-with-sentinel-1-toolbox/
https://asf.alaska.edu/how-to/data-recipes/how-to-create-glacier-velocity-maps-with-sentinel-1-toolbox/


Disaster Survey 
Mobile Application 
developed for 

Sentinel Asia.

THANK YOU
Geoinformatics Center, Asian Institute of Technology
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