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Overview
Flood in Central Java, Indonesia on March 2024

● Extreme weather and heavy rainfall caused floods 

and flash floods in Central Java, which overwhelmed 

river systems and hydrological infrastructure (dam 

failures) across the northern coast region. 

● In some areas, heavy rainfall has started since 

February and continues until mid to the end of March.

● Affected areas include Kota Semarang, Kota Jepara, 

Pekalongan, Kendal, Demak, Rembang, Blora, Pati, 

Kudus, and Grobogan (BPBD Jateng).

● Damages to public infrastructure and hundreds of 

thousands of residents were affected by the floods. Kecamatan Karanganyar, Kebupaten Demak, Jawa Tengah, 

Sunday (17/3/2024)

● Sentinel Asia was activated on 20 March 2024 at the request of the National Research and Innovation Agency (BRIN).

● Archive and crisis images were obtained from multiple sources, including ALOS-2 from the Japan Aerospace 

Exploration Agency (JAXA), FORMOSAT-5 from the Taiwan Space Agency (TASA), TelEOS-1 from the Centre for 

Remote Imaging Sensing and Processing (CRISP), and Resourcesat-2 from the Indian Space Research Organization 

(ISRO).



Overview
Flood in Central Java, Indonesia on March 2024



The objective of this exercise is to generate a flood map from ALOS-2 SAR data 

by performing a complete processing workflow consisting of data pre-processing, 

flood classification using a threshold-based binary method, and post-processing 

refinement techniques. 

The final product aims to produce accurate flood boundary delineation for 

emergency response purposes.
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Objective



In this exercise, we will use QGIS software. 

The following data are available: 

• ALOS-2 Level 2.1
• Geometrically corrected (orthorectified) data using the digital elevation data from Level 1.1.

• Observation mode: Stripmap, Dual Polarization (HH and HV)

• Spatial resolution: 6.25m, Data format: GeoTIFF

• Date: 24 March 2024 (observe), 31 December 2023 (archive)

• Ancillary data
• Copernicus 30m DEM

• OSM permanent water data

Overview
Data and Software



Methodology
Flood mapping using ALOS-2 data (single post-disaster data)
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Methodology
Flood mapping using ALOS-2 data (pre- and post-disaster data)
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Data Pre-processing
Follow Along: Open ALOS-2 data (24 March 2024)

1. In the Menu Bar, click on Layer → Add Layer 

→ Add Raster Layer.

2. In Data Source, click on the Browse button 

and navigate to the file IMG-HH-

ALOS2531187050-240324-FBDR2.1GUA.tif 

in the ALOS-2 L2.1 archive data folder.

3. With this file selected, click Add, then Close. 

The data you specified will now load.
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Data Pre-processing
Follow Along: Reprojection

1. In the Menu Bar, click on Raster → Projection 

→ Warp (Reproject).

2. In the Input Layer, select IMG-HH-

ALOS2531187050-240324-FBDR2.1GUA

3. In the Target CRS (optional), click  

4. Select Predefined CRS, then EPSG:32749 –

WGS84 / UTM Zone 49S.

5. Save the result to 

ALOS2_HH_240324_UTM49S.tif

6. Click Run.
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Data Pre-processing
Follow Along: Change the project CRS

1. In the Menu Bar, click Project → Properties.

2. Select EPSG:32749 – WGS84 / UTM Zone 

49S

3. Click OK.
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Data Pre-processing
Follow Along: Radiometric calibration

Digital number in the ALOS-2 JAXA product is 

converted to backscattering coefficient (sigma naught, 

sigma zero) using the following equations:

1. In the Menu Bar, click on Raster → Raster 

Calculator.

2. In the Raster Calculation Expression write:     

20 *  log10 ( "ALOS2_HH_240324_UTM49S@1" )  

- 83

3. Save the result to 

ALOS2_HH_240324_UTM49S_calibrated.tif

4. Click OK.
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Data Pre-processing
Follow Along: Speckle filtering

1. In the Menu Bar, click Processing → Toolbox.

2. Search for OTB → Image filtering → Despeckle

3. In the Input Layer, select 

ALOS2_HH_240324_UTM49S_calibrated

4. In the Speckle filtering method, select lee.   

5. In the Radius (optional), write 3. The unit of radius is 

pixel.

6. Save the result to 

ALOS2_HH_240324_UTM49S_calibrated_filtlee3.tif

7. Click Run.

3

4

5

6

7

2



Data Pre-processing
Follow Along: Save your work!

You can open the calibrated image and observe the 

object on the image. Can you visually identify any 

inundated areas here?

Now would be a good time to save your work.

1. In the Menu Bar, click on Project → Save As

2. Save the map in the working folder: 

ALOS2_flood_mapping_Central_Java.qgs



Determine a Threshold Value
Follow Along: (Option 1) Manual visual observation

You can determine threshold values by a manual 

visual observation. Flooded areas often appear as 

dark regions in SAR images because open water 

surfaces cause specular reflection, resulting in 

lower backscatter returns. Examine the image and 

incrementally adjusts the threshold value while 

seeking a value that best separates flooded and 

non-flooded areas.

1. Use Identify Features tool to inspect the 

backscatter value. Click on a specific pixel on 

the image to find out the value.
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Determine a Threshold Value
Follow Along: (Option 2) Histogram analysis

Determine the threshold based on the histogram of the 

whole filtered image.

1. Right-click on the 

ALOS2_HH_240324_UTM49S_calibrated_filtlee3

layer in the Layers list and select the menu item 

Properties in the menu that appears.

2. Select the Histogram tab  

3. In the Raster Histogram window, click Compute 

Histogram button.

4. A histogram is calculated. Ideally, we look for bimodal 

histograms, where water and land have two distinct 

peaks in the backscatter value distribution.
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Determine a Threshold Value
Follow Along: (Option 2) Histogram analysis

Since the threshold between two peaks was difficult to get 

for the whole image histogram, we will determine the 

threshold based on the histogram of the selected areas.

First, we have to create a polygon shapefile with the 

selected areas:

1. In the Menu Bar, click on Layer → Create Layer →

New Shapefile Layer.

2. In File name, save the results as selected_areas.shp.

3. In Geometry type, select Polygon.

4. In Projection system, select EPSG:32749 – WGS84 / 

UTM Zone 49S

5. OK.

2

3

4

5



Determine a Threshold Value
Follow Along: (Option 2) Histogram analysis

Go to editing mode to start digitizing:

1. Your new empty vector layer will appear in the Layers 

panel. In the Tool Bar, click on Toggle Editing        to 

start digitizing.

2. In the Tool Bar, click on          to add polygon. Click to 

place each vertex on the image. Right-click to finish 

the shape. Leave attribute values empty. Create 

several polygons that include water and non-water 

pixels.

3. After digitizing, click Save Layer Edits         on the 

toolbar.

4. Click on Toggle Editing        again to finish digitizing.



Determine a Threshold Value
Follow Along: (Option 2) Histogram analysis

Next, we will clip the image based on the created 

polygons:

1. In the Menu Bar, click on Raster → Extraction → 
Clip Raster by Mask Layer.

2. In the Input Layer, select 
ALOS2_HH_240324_UTM49S_calibrated_filtlee3

3. In the Mask Layer, select selected_areas.

4. Save the result to selected_areas.tif.

5. Click Run.
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Determine a Threshold Value
Follow Along: (Option 2) Histogram analysis

Compute the histogram for the clipped image.

1. Right-click on the selected areas layer in the 
Layers list and select the menu item Properties in 
the menu that appears.

2. Select the Histogram tab  

3. In the Raster Histogram window, click Compute 
Histogram button.

4. A histogram is calculated. Notice there are two 
histogram peaks now: the lower value refers to 
water pixels, while the higher value refers to non-
water pixels.

5. Determine the threshold by identifying the pixel 
value between water and non-water: ~-14 dB.
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Binary Classification
Follow Along: Create a binary map based on the threshold value

We will use the threshold value from the second 

option's result: -14 dB.

1. Click on Raster → Raster Calculator.

2. In the Raster Calculation Expression write:     " 

"ALOS2_HH_240324_UTM49S_calibrated_filtlee

3@1" < -14

3. In the Spatial Extent, define the extent based on 

the image.

4. Save the result to "ALOS2_HH_240324_binary.tif

5. Click OK.

2

4

5

3



Binary Classification
Visualization



Post-processing
Follow Along: Eliminate pixels found in slope > 5 deg.

First, let’s open DEM for the area, 30m Copernicus 

extracted from OpenTopography.

1. In the Menu Bar, click on Layer → Add Layer →

Add Raster Layer.

2. In Data Source, click on the Browse button     

and navigate to the file dem_COP30.tif in the 

ancillary data folder.

3. With this file selected, click Add, then Close. The 

data you specified will now load.
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Post-processing
Follow Along: Eliminate pixels found in slope > 5 deg.

Now, we are ready to remove misclassified pixels in 

the regions of steep slopes.

First, let’s calculate the slope from the DEM:

1. Calculate Slope: Raster → Analysis → Slope.

2. In the Input Layer, select dem_COP30

3. Save the result to slope_COP30.tif

4. Click Run.
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Post-processing
Follow Along: Eliminate pixels found in slope > 5 deg.

Use Raster Calculator to remove regions with a slope 

above 5 degrees.

1. Click on Raster → Raster Calculator.

2. In the Raster Calculation Expression write:     

if ( "slope_COP30@1" < 5, 

"ALOS2_HH_240324_binary@1", 0 )  

3. In the Spatial Extent, define the extent based on 

the image.

4. Save the result to 

ALOS2_HH_240324_binary_cl1.tif

5. Click OK.
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Post-processing
Follow Along: Eliminate permanent water areas

First, let’s open permanent water data for the area, 

extracted from OSM.

1. In the Menu Bar, click on Layer → Add Layer →

Add Raster Layer.

2. In Data Source, click on the Browse button     

and navigate to the file osm_pwater.tif in the 

ancillary data folder.

3. With this file selected, click Add, then Close. The 

data you specified will now load.
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Post-processing
Follow Along: Eliminate permanent water areas

Use Raster Calculator to eliminate permanent water 

areas.

1. Click on Raster → Raster Calculator.

2. In the Raster Calculation Expression write:     

if ( "osm_pwater@1" != 1, 

"ALOS2_HH_240324_binary_cl1@1“, 0 )   

3. In the Spatial Extent, define the extent based on 

the image.

4. Save the result to 

ALOS2_HH_240324_binary_cl2.tif

5. Click OK.
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Post-Processing
Follow Along: Remove isolated pixels

We will remove small, isolated misclassified pixels or 

noise in the binary map using a majority filter. 

1. In the Menu Bar, click Processing → Toolbox.

2. Search for SAGA Next Gen → Raster filter →

Major/minority filter

3. In the Grid input, select 
ALOS2_HH_240324_binary_cl2.

4. Change Kernel Type to Square and keep other 
parameters as default. You may want to test with 
different threshold and radius.

5. Save the result to 
ALOS2_HH_240324_binary_cl3.sdat

6. Click Run
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Post-Processing
Visualization



Post-Processing
Follow Along: Vectorize flood pixels

We will convert the flood raster to polygons.

1. Click on Raster → Conversion → Polygonize 

(Raster to Vector)…

2. In the Input Layer, select 

ALOS2_HH_240324_binary_cl3

3. Save the Vectorized result to 

ALOS2_HH_240324_flood.shp

4. Click Run.
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Post-processing
Follow Along: Remove non-water polygons

Let’s remove non-water polygons.

1. In Toolbars, activate the editing mode by 

clicking the Toggle Editing button.

2. In Toolbars, click Select Features by Value

button or click F3.

3. In the DN value, write 0. 

4. Click Select Features, then Close. 

5. In Toolbars, click Delete Selected button to 

delete non-water polygons.

6. Click Toggle Editing button again to stop the 

editing, then select Save.
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Post-processing
Final visualization



Disaster Survey 
Mobile Application 
developed for 

Sentinel Asia.

THANK YOU
Geoinformatics Center, Asian Institute of Technology
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