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Overview
Peer-reviewed paper to follow in the exercise
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Wangchuk et al. (2019). Towards automated mapping and 

monitoring of potentially dangerous glacial lakes in Bhutan 

Himalaya using Sentinel-1 Synthetic Aperture Radar data. 

Int. Journal of Remote Sensing, 

https://doi.org/10.1080/01431161.2019.1569789

The paper presents a semi-automated 

approach, based on a radar signal 

intensity threshold between water and 

non-water feature classes followed by 

post-processing including elevations, 

slopes, vegetation, and size thresholds,

https://doi.org/10.1080/01431161.2019.1569789


Overview
Methodology
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In this exercise, we will use QGIS software. The following data are available: 
• Sentinel-1 Interferometric Wide (IW) swath mode product.

• Radiometric Terrain Correction (RTC) data generated by ASF Vertex (check the Tutorial on 
Searching and Obtaining Satellite Data). GLO-30 Copernicus DEM is also included here.

• Date: 05 July 2025
• Spatial resolution 10m

• Sentinel-2 Level-2A product
• Atmospherically corrected Surface Reflectance (SR) products from Level-1C products.
• Date: 29 April 2024
• Spatial resolution: 10m (B2, B3, B4, B8, TCI, AOT, WVP), 20m (B5, B6, B7, B8A, B11, B12, AOT, 

CLD, SCL, SNW, WVP), 60m (B1, B9, AOT, CLD, SCL, SNW, WVP)

• Glacial lake inventory data (Wang et al., 2020)
• Data was generated using Landsat data for the year 1990. 2000. 2010, 2015. and 2020.
• Covered the area of Hindu Kush, Karakoram, Western Himalaya, Central Himalaya, Eastern 

Himalaya, Nyainqêntanglha, and Hengduan Shan.
• Dataset is freely available from 

https://figshare.com/articles/dataset/Glacial_lake_inventory_1990_2000_2010_2015_and_2020_in_t
he_greater_Himalaya/21708590?file=39643498

• Area of Interest (AOI) in shapefile 4

Overview
Data and Software

https://figshare.com/articles/dataset/Glacial_lake_inventory_1990_2000_2010_2015_and_2020_in_the_greater_Himalaya/21708590?file=39643498
https://figshare.com/articles/dataset/Glacial_lake_inventory_1990_2000_2010_2015_and_2020_in_the_greater_Himalaya/21708590?file=39643498


Data Preparation
Follow Along: Open Sentinel-1 RTC data (05 July 2025)

1. In the Menu Bar, click on Layer → Add 

Layer → Add Raster Layer.

2. In Data Source, click on the Browse

button and navigate to the file 

S1A_IW_20250705T001933_DVR_RT

C10_G_gdufem_E688_VV.tif in the 

data folder.

3. With this file selected, click Add, then 

Close. The data you specified will now 

load.
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Data Preparation
Follow Along: Open Area of Interest (AOI)

1. In the Menu Bar, click on Layer → Add 

Layer Add Layer → Add Vector Layer.

2. In Data Source, click on the Browse

button and navigate to the file aoi.shp in 

the data folder.

3. With this file selected, click Add, then 

Close. The data you specified will now 

load.

2

3



Data Preparation
Follow Along: Clip the Sentinel-1 image

1. Click on Raster → Extraction → Clip 

Raster by Mask Layer.

2. In the Input Layer, select 

S1A_IW_20250705T001933_DVR_R

TC10_G_gdufem_E688_VV

3. In the Mask Layer, select aoi.

4. Save the result to 

S1A_IW_20250705_VV.tif

5. Click Run.
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Data Preparation
Follow Along: Save your work!

You can open the clipped image and observe 

the object on the image. Can you visually 

identify any glacial lakes here?

Now would be a good time to save your work.

1. In the Menu Bar, click on Project → Save 

As

2. Save the map in the working folder and 

call it glacial_lake_Nepal.qgs



Determine a Threshold Value
Follow Along: (Option 1) Manual visual observation

You can determine threshold values by a manual 

visual observation. Flooded areas often appear as 

dark regions in SAR images because open water 

surfaces cause specular reflection, resulting in 

lower backscatter returns. Examine the image and 

incrementally adjusts the threshold value while 

seeking a value that best separates flooded and 

non-flooded areas.

1. Use Identify Features tool to inspect the 

backscatter value. Click on a specific pixel on 

the image to find out the value.
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Determine a Threshold Value
Follow Along: (Option 2) Histogram analysis

Check the histogram of the whole clipped image.

1. Right-click on the S1A_IW_20250705_VV layer 

in the Layers list and select the menu item 

Properties in the menu that appears.

2. Select the Histogram tab  

3. In the Raster Histogram window, click Compute 

Histogram button.

4. A histogram is calculated. Ideally, we look for 

bimodal histograms, where water and land have 

two distinct peaks in the backscatter value 

distribution.

2



Determine a Threshold Value
Follow Along: (Option 2) Determine a threshold value

Since determining the threshold for the entire image 
histogram was difficult, we will calculate the threshold 
based on the histograms of specific known lakes. The 
available inventory of glacial lakes will be used here.

Open glacial lake inventory:

1. In the Menu Bar, click on Layer → Add Layer Add 
Layer → Add Vector Layer.

2. In Data Source, click on the Browse button and 
navigate to the file GlacialLake_2020.shp in the data 
folder.

3. With this file selected, click Add, then Close. The data 
you specified will now load.
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3Note: In the paper, the Otsu algorithm was used to determine 
the threshold automatically. We’ll not do it now because we 
cannot do this process directly in QGIS, but it is possible to 
write a Python script to then run it in QGIS.



Determine a Threshold Value
Follow Along: (Option 2) Determine a threshold value

The inventory data comes in another different 

projection: Asia_North_Albers_Equal_Area. We will 

reproject the data first to match our satellite data’s 

projection: UTM Zone 45N.

4. In the Menu Bar, click on Vector → Data 
Management Tools → Reproject Layer.

5. In the Input Layer, select GlacialLake_2020.

6. In the Target CRS, select Project CRS: 
EPSG:32645 – WGS 84 / UTM zone 45N.

7. Save the result to GlacialLake_2020 _45N.shp.

8. Click Run.
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Determine a Threshold Value
Follow Along: (Option 2) Determine a threshold value

We will only select the glacial lakes that are included 

in the AOI.

9. In the Tool Bar, click on Select Features by Area 
or Single Click         button.

10.Select the lake polygons from the 
GlacialLake_2020 _45N layer over the AOI using 
your Shift and left-click mouse. The selected 
polygon will be highlighted in yellow.

11.Right-click on the GlacialLake_2020 _45N layer 
in the Layers list, click Export → Save Selected 
Features As…

12.Save the result to GlacialLake_2020 
_45N_selected.shp.

13.Click OK.
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Determine a Threshold Value
Follow Along: (Option 2) Determine a threshold value

We will create a 90m buffer around the glacial lakes 

to include the non-water area surrounding the lakes.

14. In the Menu Bar, click on Vector → 
Geoprocessing Tools → Buffer.

15. In the Input Layer, select GlacialLake_2020 
_45N _filtered.

16. In the Distance, type 90.

17. In the End cap style, select Flat

18.Save the result to GlacialLake_2020 _45N 
_buffered.shp.

19.Click Run.
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Determine a Threshold Value
Follow Along: (Option 2) Determine a threshold value

We will use this buffered lakes to clip the image. This 
step ensures the normalization of the frequency of 
occurrence of water and non-water pixels to obtain a 
bimodal histogram.

20.Click on Raster → Extraction → Clip Raster by 
Mask Layer.

21. In the Input Layer, select S1A_IW_20250705_VV

22. In the Mask Layer, select GlacialLake_2020 
_45N _buffered.

23.Save the result to S1A_IW_ 20250705 
_VV_bufferedLakes.tif

24.Click Run.
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Determine a Threshold Value
Follow Along: (Option 2) Determine a threshold value

We will determine the threshold based on the histogram of 
the buffered lakes image.

25.Right-click on the S1A_IW_ 20250705 
_VV_bufferedLakes layer in the Layers list and select 
the menu item Properties in the menu that appears.

26.Select the Histogram tab  

27. In the Raster Histogram window, click Compute 
Histogram button.

28.A histogram will be calculated. Notice there are two 
histogram peaks: the lower value refers to water 
pixels, while the higher value refers to non-water 
pixels.

29.Determine the threshold by identifying the pixel value 
in between water and non-water: ~ -14 dB
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Glacial Lake Mapping
Follow Along: Create a binary map based on the threshold value

We will use the threshold value from the second 

option's result: -14 dB. The average threshold value 

given in the paper is -14.52 dB, which is not far from our 

result.

1. Click on Raster → Raster Calculator.

2. In the Raster Calculation Expression write:             

" S1A_IW_20220705_VV@1 " < -14

3. In the Spatial Extent, define the extent based on 

the aoi.

4. Save the result to S1A_IW_ 20220705 

_VV_output1.tif

5. Click OK.
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Glacial Lake Mapping
Follow Along: Create a binary map bases on the threshold value



Post-Processing: Glacial Lake Mapping
Follow Along: Eliminate pixels found in elevation > 5,600m

We will remove pixels found at elevations above 

5,600m, where glacial lakes are hardly found above 

this elevation threshold in the Himalayas (Zhang et 

al., 2015)

1. In the Menu Bar, click on Layer → Add Layer →

Add Raster Layer.

2. In Data Source, click on the Browse button and 

navigate to the file 

S1A_IW_20250705T001933_DVR_RTC10_G_g

dufem_E688_dem.tif in the data folder.

3. With this file selected, click Add, then Close. The 

data you specified will now load.
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Post-Processing: Glacial Lake Mapping
Follow Along: Eliminate pixels found in elevation > 5,600m

Clip the DEM based on AOI

4. In the Menu Bar, click on Raster → Extraction → 

Clip Raster by Mask Layer.

5. In the Input Layer, select 

S1A_IW_20250705T001933_DVR_RTC10_G_g

dufem_E688_dem

6. In the Mask Layer, select aoi.

7. Save the result to dem.tif

8. Click Run.
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Post-Processing: Glacial Lake Mapping
Follow Along: Eliminate pixels found in elevation > 5,600m

Use Raster Calculator to remove elevation above 

5,600m.

9. Click on Raster → Raster Calculator.

10. In the Raster Calculation Expression write:          

if ( "dem@1" < 5600 AND "dem@1" > 0, " 

S1A_IW_20250705_VV_output1.tif @1", 0)

11. In the Spatial Extent, define the extent based on 

the aoi.

12.Save the result to 

S1A_IW_20250705_VV_output2.tif

13.Click OK.
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Post-Processing: Glacial Lake Mapping
Follow Along: Eliminate pixels found in elevation > 5,600m



Post-Processing: Glacial Lake Mapping
Follow Along: Eliminate pixels found in slope > 30 deg.

We will remove misclassified pixels in the regions of 

steep slopes.

Calculate the slope from DEM:

1. Calculate Slope: Raster → Analysis → Slope.

2. In the Input Layer, select dem

3. Save the result to slope.tif

4. Click Run.
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Post-Processing: Glacial Lake Mapping
Follow Along: Eliminate pixels found in slope > 30 deg.

Use Raster Calculator to remove elevation above 

5,600m.

5. Click on Raster → Raster Calculator.

6. In the Raster Calculation Expression write:          

if ( "slope@1" < 30, " 

S1A_IW_20250705_VV_output2.tif@1", 0)

7. In the Spatial Extent, define the extent based on 

the aoi.

8. Save the result to 

S1A_IW_20250705_VV_output3.tif

9. Click OK.

6

8

9

7



Post-Processing: Glacial Lake Mapping
Follow Along: Eliminate pixels found in slope > 30 deg.



Post-Processing: Glacial Lake Mapping
Follow Along: Eliminate pixels found in NDVI > 0

We will use Sentinel-2 data on 29 April 2024 to 

calculate the Normalized Difference Vegetation Index 

(NDVI) to remove vegetated areas.

Open the Sentinel-2 data

1. Drag and drop the Sentinel-2 zip file to the Map 

View or Layer List. 

2. Select the first layer that contain B2 (Blue), B3 

(Green), B4 (Red), and B8 (Near Infrared) bands.

3. Click Add Layers.
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Post-Processing: Glacial Lake Mapping
Follow Along: Eliminate pixels found in NDVI > 0

Clip the Sentinel-2 data based on AOI

4. In the Menu Bar, click on Raster → Extraction → 

Clip Raster by Mask Layer.

5. In the Input Layer, select 

S2B_MSIL2A_20240429T045659_N0510_R119

_T45RUM_20240429T075820.SAFE.zip

6. In the Mask Layer, select aoi.

7. Save the result to S2B_20240429.tif

8. Click Run.
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Post-Processing: Glacial Lake Mapping
Follow Along: Eliminate pixels found in NDVI > 0

Calculate NDVI using the following equation:      

(B8:NIR – B4:RED) / (B8:NIR + B4:RED).

9. In the Menu Bar, click on Raster → Raster 

Calculator.

10. In the Raster Calculation Expression, write:     

("S2B_20240429@4" - "S2B_20240429@1")  /  

("S2B_20240429@4" + "S2B_20240429@1")

11. In the Spatial Extent, define the extent based on 

the aoi.

12.Save the result to ndvi.tif

13.Click OK.
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Post-Processing: Glacial Lake Mapping
Follow Along: Eliminate pixels found in NDVI > 0

Use Raster Calculator to remove pixels with NDVI 

above zero.

14.Click on Raster → Raster Calculator.

15. In the Raster Calculation Expression write:     

if ( "ndvi@1" < 0, "

S1A_IW_20250705_VV_output3 @1", 0 )

16. In the Spatial Extent, define the extent based on 

the aoi.

17.Save the result to 

S1A_IW_20250705_VV_output4.tif

18.Click OK.
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Post-Processing: Glacial Lake Mapping
Follow Along: Eliminate pixels found in NDVI > 0



Post-Processing: Glacial Lake Mapping
Follow Along: Vectorize potential glacial lake pixels

We will convert the potential glacial lake raster to 

polygons.

1. Click on Raster → Conversion → Polygonize 

(Raster to Vector)…

2. In the Input Layer, select 

S1A_IW_20250705_VV_output4

3. Save the Vectorized result to output_ 

20250705.shp

4. Click Run.
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Post-Processing: Glacial Lake Mapping
Follow Along: Remove non-water polygons

We will modify the polygons to clean the results 

further. First, let’s remove non-water polygons.

1. In Toolbars, activate the editing mode by 

clicking the Toggle Editing button.

2. In Toolbars, click Select Features by Value

button.

3. In the DN value, write 0. 

4. Click Select Features, then Close. 

5. In Toolbars, click Delete Selected button to 

delete non-water polygons.
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Post-Processing: Glacial Lake Mapping
Follow Along: Remove non-water polygons



Post-Processing: Glacial Lake Mapping
Follow Along: Calculate area, perimeter, and compactness ratio (CR)

Calculate area of each polygon in the attribute table.

1. Right-click on the layer, then click Open Attribute 

Table button.

2. In the Table Toolbars, click Open Field Calculator

button.

3. In Output field name, write area.

4. In Output field type, select Decimal number (real).

5. Expand the Geometry and double-click $area. The 

text will be added to the Expression box. 

6. Click OK.
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Post-Processing: Glacial Lake Mapping
Follow Along: Calculate area, perimeter, and compactness ratio (CR)

Calculate perimeter of each polygon in the attribute 

table.

7. In the Table Toolbars, click again Open Field 

Calculator button.

8. In Output field name, write perimeter.

9. In Output field type, select Decimal number 

(real).

10.Expand the Geometry and double-click 

$perimeter. The text will be added to the 

Expression box. 

11.Click OK.
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Post-Processing: Glacial Lake Mapping
Follow Along: Calculate area, perimeter, and compactness ratio (CR)

Calculate CR of each polygon in the attribute table. 

The Polsby-Popper test will be used to measure the 

compactness of a shape.

12. In the Table Toolbars, click again Open Field 

Calculator button.

13. In Output field name, write CR.

14. In Output field type, select Decimal number 

(real).

15.Write this equation in the Expression box:             

(4 * pi() * $area) / ($perimeter ^ 2)

16.Click OK.
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Post-Processing: Glacial Lake Mapping
Follow Along: Select and extract potential areas based on area and CR

Potential lake areas will be selected based on area size and 

compactness ratio (CR). All areas of 0.01 sq.km or larger will be 

included automatically based on size alone. However, for areas 

between 0.01 sq.km and 0.1 sq.km, selection requires that they also 

meet a compactness ratio threshold of CR > 0.01.

1. In the Table Toolbars, click Select features using an expression

button.

2. Expand the Field and Values and double-click area and CR to use 

them in the Expression box. Complete the expression: 

("area" > 10000 AND  "CR" > 0.1)  OR  "area" > 100000

3. Click Select Features, then Close.

4. In the Table Toolbars, click  Invert selection      button.

5. In the Table Toolbars, click  Delete selected features button.

6. In Toolbars, click Toggle Editing button to close the editing 

mode. Don’t forget to click Save button in the confirmation box.
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Post-Processing: Glacial Lake Mapping
Follow Along: Select and extract potential areas based on area and CR



Post-Processing: Glacial Lake Mapping
Follow Along: Fill in the holes in the polygons

To finalize the post-processing, we will fill in the holes 

in the glacial lake polygons.

1. Click on Processing → Toolbox. Search for 

Delete Holes tool.

2. In the Input Layer, select output_ 20250705

3. Save the result to output_ 20250705 _final.shp

4. Click Run.
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Post-Processing: Glacial Lake Mapping
Final Glacial Lake Map



Post-Processing: Glacial Lake Mapping
Follow Along: Intersect with the inventory

To finalize the post-processing, we will fill in the holes 

in the glacial lake polygons.

1. In the Menu Bar, click on Vector → 

Geprocessing Tools → Intersection.

2. In the Input Layer, select output_ 20250705_final

3. In the Overlay Layer, select 

GlacialLake_2020_45N_selected

4. Save the result to output_ 20250705 

_final_intersect.shp

5. Click Run.
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Post-Processing: Glacial Lake Mapping
Final Glacial Lake Map after intersect with the inventory



We’ve completed the exercise for glacial lake mapping using QGIS software. 

● We used the Sentinel-1 RTC data on 05 July 2025 to extract glacial lake 

features, with the additional data from Sentinel-2 and GLO-30 Copernicus 

DEM for post-processing.

● You can also process the archive Sentinel-2 RTC data on 10 July 2024

following the same step-by-step method. The result can be used to perform 

multi-temporal analysis and evaluate the changes of glacial lake between 

2024 and 2025.

● (Optional) Demo on automatic glacial lake mapping with Python.
43
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Disaster Survey 
Mobile Application 
developed for 

Sentinel Asia.

THANK YOU
Geoinformatics Center, Asian Institute of Technology
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