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Overview

Sentinel Asia activation:

Flood in Nepal

• Occurrence Date (UTC): 30 June, 
2025 and 08 July 2025

• SA activation Date(UTC): 01 July, 
2025

• Requester: Department of 
Hydrology and Meteorology 
(DHM), Ministry of Energy, Water 
Resources and Irrigation

(https://sentinel-asia.org/EO/2025/article20250630NP.html)



The objective of this exercise is to generate a damage proxy map by analyzing 

coherence changes derived from pre- and post-event Sentinel-1 SLC (Single 

Look Complex) data. 

This exercise aims to detect areas affected by flooding based on significant 

coherence loss, supporting rapid disaster response and impact assessment in 

urban environments.

Note: The exercise is adapted from the UN-SPIDER Recommended Practice for Flood Mapping with 

Sentinel-1 Interferometric Coherence

Overview
Objective



In this exercise, we will use SNAP, QGIS, and Google Earth Engine (GEE). 

The following data are available: 

• Sentinel-1 SLC (Single Look Complex)
• Contain magnitude and phase information represented by complex I and Q numbers. Range 

coordinate is in slant range.

• Sentinel-1 Terrain Observation by Progressive Scans SAR (TOPS) captures data in bursts, 

which are segments of radar echoes acquired by cyclically switching the antenna beam across 

multiple sub-swaths. Sentinel-1 SLC data are split into bursts per sub-swath. 

• Observation mode: Interferometric Wide (IW).

• Dual Polarization (VH and VV), Data format: SAFE structure

• Date: 9 July 2025 (observe), 15 and 27 June 2025 (archive)

Overview
Data and Software



Methodology
Damage Proxy mapping using Sentinel-1 coherence changes
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Methodology
Damage Proxy mapping using Sentinel-1 coherence changes
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1. Main Menu

2. Tool Bars

3. Product Explorer

4. Image View

5. Other windows: Navigation, Color 

Manipulation, World View, etc.

1

2

3

4

5

Data Exploration in SNAP
Open the SNAP software



1. In the Main Menu, go to File → Open 

Product…

2. Browse to the location of the data. Then 

select all Sentinel-1 data in both archive 

and observe folders. Each file refers to a 

different acquisition date.

3. Click Open
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Data Exploration in SNAP
Open Sentinel-1 Data
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The opened products will appear 

in the Product Explorer window. 

1. Click > to expand the contents 

of the product [1], then expand 

the Bands folder. You can see 

three sub-swaths (IW1, IW2, 

IW3). Expand one of the folder 

and you will see the complex 

data and intensity for each VH 

and VV polarizations. 

2. Double-click on the i_IW1_VH, 

q_IW1_VH (complex data), 

and Intensity_IW1_VH band to 

visualize it. 

Data Exploration in SNAP
Explore the Sentinel-1 Data



We will use the Batch Processing tool available in SNAP to apply all steps to both images in one go (this also saves 

disk space as only the final product is physically saved).

1. In the Main Menu, go to 

Tools → GraphBuilder
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2. The Graph Builder window 

will show up. 

In the beginning, the graph has 

only two operators: Read (to 

read the input) and Write (to 

write the output). We will create 

a step-by-step workflow to apply 

identical pre-processing steps to 

both of our scenes.

You can delete the Write

operator for now (Right-click on 

the operator and select Delete).

Data Processing in SNAP
Open Graph Builder



We will create two more Read operators in addition to the default one because we have three input data.

1. In the Main Menu, go to 

Tools → GraphBuilder
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2. The Graph Builder window 

will show up. 

In the beginning, the graph has 

only two operators: Read (to 

read the input) and Write (to 

write the output). We will create 

a step-by-step workflow to apply 

identical pre-processing steps to 

both of our scenes.

You can delete the Write

operator for now (Right-click on 

the operator and select Delete).

Data Processing in SNAP
Prepare Read operators



1. To add the operator right-click the white space 

between the existing operators and go to Add → 

Input-Output → Read

2. A new Read operator rectangle appeared in our 

graph. Add one more Read operator.

3. Notice that a new tab also appeared below the 

graph.

4. In each Read tabs, select the scenes in the right 

order. 

• Read = Pre-event 1 (20250615)

• Read(2) = Pre-event 2 (20250627)

• Read(3) = Post-event  (20250709)

Data Processing in SNAP
Prepare Read operators
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• The orbit state vectors provided in the metadata of a SAR product are 

generally not accurate and can be refined with the precise orbit files which 

are available days-to-weeks after the generation of the product. 

• The orbit file provides accurate satellite position and velocity information. 

Based on this information, the orbit state vectors in the abstract metadata 

of the product are updated. 

Data Processing in SNAP
Update the orbit metadata 



1. Right-click the white space 

between the existing operators 

and go to Add → Radar → Apply-

Orbit-File.
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3. Now connect the new  

Apply-Orbit-File

operator with the 

Read operator by 

clicking to the right 

side of the Read 

operator and dragging 

the red arrow towards 

the Apply-Orbit-File

operator. Do the same 

to all.

4. Check that the new 

tabs appear below the 

graph. Choose 

Sentinel Precise (Auto 

Download).
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Data Processing in SNAP
Update the orbit metadata 
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• Sentinel-1 SLC images in Interferometric Wide (IW) mode typically consist 

of 3 sub-swaths (IW1, IW2, IW3) — each composed of multiple bursts.

• The TOPSAR Split operator provides a convenient way to split each sub-

swath with selected bursts into a separate product. 

• The user may select the desired sub-swath with desired bursts and 

polarizations. 

Data Processing in SNAP
TOPSAR Split



Data Processing in SNAP
TOPSAR Split

1. Right-click the white space between the existing 

operators and go to Add → Radar → Sentinel-1 

TOPS → TOPSAR-Split.

2. Connect the new operator with the Apply-Orbit-File 

operators. 

3. Select the Subswath: IW2 because this subswath

cover our study area

4. Select VV polarization.
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• Due to satellite movement, orbital drift, and acquisition differences, 

reference and secondary SLC images need to be geometrically matched.

• This operator co-registers two S-1 SLC split products (reference and 

secondary) of the same sub-swath using the orbits of the two products and 

a Digital Elevation Model (DEM).

Data Processing in SNAP
Back Geocoding



Data Processing in SNAP
Back Geocoding

1. Right-click the white space between the existing operators 

and go to Add → Radar → Coregistration → S1-TOPS 

Coregistration → Back Geocoding 

2. Connect the new operator with all TOPSAR-Split operators. 

3. Select DEM: Copernicus 30m. 

4. Uncheck “Mask out areas with no elevation”. It is 

recommended to avoid artefacts along the coast in the co-

registered images.
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• Coherence is a measure of the similarity in radar signal phase and 

amplitude between two SAR images acquired at different times, for the 

same location.

• The Coherence Estimation operator in SNAP calculates the interferometric 

coherence between a pair of co-registered Sentinel-1 SLC images 

(reference and secondary).

Data Processing in SNAP
Coherence Estimation



Data Processing in SNAP
Coherence Estimation

1. Right-click the white space between the existing operators 

and go to Add → Radar → Interferometric → Products → 

Coherence 

2. Connect the new operator with Back-Geocoding operator. 

3. Keep the default settings.
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• Each sub-swath consists of a series of adjacent but slightly overlapping 

bursts, which can cause visible discontinuities (burst gaps) in the 

interferogram.

• Debursting removes those discontinuities and stitches the bursts together 

to create a continuous, seamless image for each sub-swath.

Data Processing in SNAP
TOPSAR Deburst



Data Processing in SNAP
TOPSAR Deburst

1. Right-click the white space between the existing operators 

and go to Add → Radar → Sentinel-1 TOPS → TOPSAR-

Deburst 

2. Connect the new operator with the Coherence operator. 

3. Keep the default settings.
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• Multilook is a SAR image processing technique used to reduce speckle 

noise and improve the visual appearance and radiometric quality of SAR 

images by averaging neighboring pixels in range and azimuth directions.

• It can be produced by space-domain averaging of a single look image or 

by a frequency-domain method using the sub-spectral band width.

• Additionally, multi-look processing can be used to reduce the image pixel 

size.

Data Processing in SNAP
Multilook



Data Processing in SNAP
Multilook

1. Right-click the white space between the existing operators 

and go to Add → Radar → SAR Utilities → Multilook 

2. Connect the new operator with the TOPSAR-Deburst 

operator. 

3. Specify the Number of Range Looks: 4. If you check the 

GR Square Pixel option, the range and azimuth spacings 

are approximately the same in the multilooked image.

2

3



• Due to topographical variations of a scene and the tilt of the satellite 

sensor, distances can be distorted in the SAR images. 

• Image data not directly at the sensor’s Nadir location will have some 

distortion. 

• Terrain corrections are intended to compensate for these distortions so 

that the geometric representation of the image will be as close as possible 

to the real world.

• The Range Doppler Terrain Correction Operator implements the Range 

Doppler orthorectification method for geocoding SAR images from a single 

2D raster radar geometry.

Data Processing in SNAP
Terrain Correction



Data Processing in SNAP
Terrain Correction

1. Right-click the white space between the existing operators 

and go to Add → Radar → Geometric → Terrain Correction 

→ Terrain-Correction 

2. Connect the new operator with the Multilook operator. 

3. Select DEM: Copernicus 30m.
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Data Processing in SNAP
Terrain Correction

1. Let’s complete the graph with the 

output. Right-click the white space 

between the existing operators and go 

to Add → Input-Output → Write

2. Connect the new operator with the 

Terrain-Correction operator. 

3. Save and change the output directory: 

S1A_IW_SLC__1SDV_20250615T12

2227_20250615T122255_059657_07

6846_5A9F_Orb_Stack_Coh_Deb_M

L_TC

4. Save the graph, go to File → Save 

Graph in the Graph Builder Main 

Menu: Coherence_Snap.xml

5. Now that all settings are completed. 

Run the Graph.
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Here, the processing completed in ~3-4 minutes (depending on your PC/laptop)



Data Processing in SNAP
Output: Coherence

The coherence products will appear 

in the Product Explorer window. 

1. Click > to expand the contents of 

the product [1], then expand the 

Bands folder. You can see the 

coherence of pre-event (t1-t2) 

and post-event (t1-t3). Make sure 

the combinations are correct.

2. Double-click on both coherence 

bands to visualize them.

Note: If you have time, you can run the 

Graph again to process coherence for 

sub-swath IW1 and IW3. 



Coherence Changes Calculation

To quantify the impact of the July 08, 2025, event on coherence. This involves comparing the 

coherence calculated from post-event (t1-t3) with a pre-event baseline coherence (which would 

be the coherence calculated from pre-event (t1-t2). This highlights the actual change caused by 

the event.

The resulting "coherence change" map is your primary tool for damage assessment. Areas 

showing a significant drop in coherence in this final map are strong indicators of damage or 

significant surface alteration directly related to the event, as stable features would have lost 

their consistent radar scattering properties.



Data Processing in QGIS
Input Coherence results in QGIS 



➢ Using Raster Calculator tool in QGIS

Goto Raster >  Raster Calculator 
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Equation:

ABS ( "coh_IW2_VV_15Jun2025_09Jul2025@1" 

- "coh_IW2_VV_15Jun2025_27Jun2025@1" ) 

Data Processing in QGIS
Coherence Changes Calculation
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Data Processing in QGIS
Output: Coherence Changes



Data Processing in Google Earth Engine (GEE)
Load the coherence changes product to the GEE assets

1. Login to your GEE account.

2. Go to the Assets tab, then click 

NEW and GeoTIFF.

3. Click SELECT and upload the 

GeoTIFF coherence product from 

QGIS. 

4. Click UPLOAD.
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Data Processing in Google Earth Engine (GEE)
Import the coherence product to the GEE script window

1. Once uploading is complete, it will be available as Cloud Assets. You may 

have to click restart to see the product on the Assets tab.

2. Check the Tasks tab to check the uploading status.
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Data Processing in Google Earth Engine (GEE)
Copy the script and Run

1. Copy the prepared script to the 

Script window.

1

2 2. Update the file path of your image.

3 3. Run the script.



Data Processing in Google Earth Engine (GEE)
Output: Coherence Changes (Mask Slope and Urban areas)

Download



Data Processing in Google Earth Engine (GEE)
Script description

● Defines a rectangular AOI in Nepal using bounding box

● Coordinates: [85.299951, 28.177378, 85.398319, 28.296120]

● Used to clip all subsequent data layers



Data Processing in Google Earth Engine (GEE)
Script description

● Loads preprocessed Sentinel-1 Coherence image from Assets

● Coherence indicates surface change or stability between SAR acquisitions



Data Processing in Google Earth Engine (GEE)
Script description

● Uses Dynamic World dataset ('built' band)

● Takes temporal mean and thresholds >10% urban probability

● Clips to AOI



Data Processing in Google Earth Engine (GEE)
Script description

● Loads DEM from HydroSHEDS

● Computes slope using Terrain algorithm

● Masks out areas with slope ≥ 20°



Data Processing in Google Earth Engine (GEE)
Script description

● Applies slope mask to urban area layer

● Keeps only urban areas on low-slope land

● Clips the coherence image to AOI

● Applies the combined urban + slope mask

● Output: Coherence in urban + low-slope areas only



Data Processing in Google Earth Engine (GEE)
Script description

● Centers map on AOI

● Displays coherence in yellow-red palette

● Shows AOI outline in blue



Data Processing in Google Earth Engine (GEE)
Script description

● Exports final image as 'coherence_mask_urban_slope'

● Output to folder: GEE_Export

● Scale: 10m/pixel, region: AOI, format: GeoTIFF



Disaster Survey 
Mobile Application 
developed for 

Sentinel Asia.

THANK YOU
Geoinformatics Center, Asian Institute of Technology
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