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Overview
How does Synthetic Aperture Radar (SAR) detect floods?

Bangladesh floods observed by ALOS-2 Level2.1 

IMG HH ALOS2 43575/3150 2022/06/18 WBD R 2.1 GUD

• Water (calm) surface appears dark due to 

specular reflection leading to low backscatter.

• Non-water (Land) surface appear brighter due to 

the rough surface leading to higher backscatter.

Franz J Meyer, 2023
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Overview
How does Synthetic Aperture Radar (SAR) detect floods?

• The common method for flood detection and mapping is thresholding.

Histogram of two Radarsat SAR images of the same region acquired under different incidence angles. Left: 
Radarsat S2 (23◦ incidence angle). Right: Radarsat S7 (45◦ incidence angle) (Solbø & Solheim, 2004)
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Floods in Northern Thailand

Northern Thailand, particularly Chiang Rai 

Province, is experiencing significant 

flooding due to continuous heavy rainfall 

intensified by Typhoon Yagi.

• Occurrence Date (UTC): 10 Sep. 2024

• SA activation Date(UTC): 12 Sep. 2024

• Requester: Geo-Informatics and Space 

Technology Development Agency 

(GISTDA)

Note: The International Disaster Charter 

(IDC) was also activated for this event via 

another mechanism.

Overview
Sentinel Asia activation in Thailand



PRE-PROCESSING

PROCESSING

POST-PROCESSING

Workflow



In this exercise, you will work with SNAP software to perform pre-processing 

from a pair of Sentinel-1 data. QGIS will be used to identify flood pixels, clean the 

output, and visualize the map. 

Data:

● Sentinel-1 GRDH on 15 Sept. 2024 (Post-flood): 
S1A_IW_GRDH_1SDV_20240915T231601_20240915T231626_055682_06CCBA_08DA.SAFE

S1A_IW_GRDH_1SDV_20240915T231626_20240915T231651_055682_06CCBA_F73A.SAFE

● Sentinel-1 GRDH on 21 Sept. 2023 (Pre-flood): 
S1A_IW_GRDH_1SDV_20230921T231605_20230921T231630_050432_0612B3_4935.SAFE

S1A_IW_GRDH_1SDV_20230921T231630_20230921T231655_050432_0612B3_053E.SAFE
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Overview
Data and Software



1. Main Menu

2. Tool Bars
3. Product Explorer
4. Image View

5. Other windows: Navigation, Color Manipulation, 
World View, etc.

1

2

3

4

5

Data Pre-processing
Open SNAP software



1. In the Main Menu, go to 

File → Open Product…

1

2

2. Browse to the location of the data. Then select both files of Sentinel-1 data. Each 

file refers to a different acquisition date.

3. Click Open

3

Data Pre-processing
Open Sentinel-1 Data (post-flood image)

First, let’s open Sentinel-1 

images during the floods. 
The area of interest is 
covered by two scenes, so we 

will open both images here.



1. The opened products will appear in the Product Explorer window. Click > to expand the contents of the product [1], 

then expand the Bands folder and double-click on the Intensity_VV band to visualize it. You can also open other 

folders, to check the metadata and other info.

Data Pre-processing
Explore the Sentinel-1 Data

1

2. Check the World View window at the bottom left, to make sure the images are in 

the correct area.



We will use the Batch Processing tool available in SNAP to apply all steps to both images in one go 

(this also saves disk space as only the final product is physically saved).

1. In the Main Menu, open 

Tools → GraphBuilder

1

2

2. The Graph Builder window 

will show up. 

In the beginning, the graph has 

only two operators: Read (to 

read the input) and Write (to 

write the output). We will create 

a step-by-step workflow to apply 

identical pre-processing steps to 

both of our scenes.

Data Pre-processing
Open Graph Builder



• The orbit state vectors provided in the metadata of a SAR product are 

generally not accurate and can be refined with the precise orbit files which 

are available days-to-weeks after the generation of the product. 

• The orbit file provides accurate satellite position and velocity information. 
Based on this information, the orbit state vectors in the abstract metadata 

of the product are updated. 

Data Pre-processing
Update the orbit metadata 



3. To add the operator right-click the 

white space between the existing 

operators and go to Add → 

Radar → Apply-Orbit-File

3

2

4. A new operator 

rectangle appeared in 

our graph.

5. Now connect the new  

Apply-Orbit-File

operator with the 

Read operator by 

clicking to the right 

side of the Read 

operator and dragging 

the red arrow towards 

the Apply-Orbit-File

operator. 

6. Notice that a new tab 

also appeared below 

the graph.

4

5
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Data Pre-processing
Update the orbit metadata 



• Thermal noise in SAR imagery is the background energy that is generated 

by the receiver itself. 

• It skews the radar reflectivity to towards higher values and hampers the 

precision of radar reflectivity estimates. 

• Level-1 products provide a noise LUT for each measurement dataset, 

provided in linear power, which can be used to remove the noise from the 

product.

Data Pre-processing
Remove the thermal noise 



7. Right-clicking the white space somewhere 

and go to to Add → Radar → Radiometric 

→ ThermalNoiseRemoval

8. A new operator rectangle 

appeared in our graph.

9. Connect the new operator 

with the Apply-Orbit-File

operator.

8
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Data Pre-processing
Remove the thermal noise



• The Sentinel-1 GRD (ground range detected) Level-1 product has noise 

artifacts at the image borders, which are quite consistent at both the left 

and right sides of the satellite’s cross-track and at the start and end of the 

data take-along track. 

• The Sentinel-1 border noise troubles the creation of a clean and consistent 

time series of backscatter.

• These processing steps are mainly the azimuth and /range compression 

and the sampling start time changes handling that is necessary to 
compensate for the change of earth curvature.

Data Pre-processing
Remove GRD border noise



10.Right-clicking the white space somewhere 

and go to Add → Radar → Sentinel-1 

TOPS → Remove-GRD-Border-Noise

11.A new operator rectangle 

appeared in our graph.

12.Connect the new operator 

with the 

ThermalNoiseRemoval

11
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Data Pre-processing
Remove GRD Border Noise



• Typical SAR data processing, which produces level-1 images, does not 

include radiometric corrections and significant radiometric bias remains. 

• The radiometric correction is necessary for the pixel values to truly 

represent the radar backscatter of the reflecting surface and therefore for 
comparison of SAR images acquired with different sensors or acquired 

from the same sensor but at different times, in different modes, or 

processed by different processors.

Data Pre-processing
Calibration



13.Right-clicking the white space somewhere 

and go to Add → Radar → Radiometric → 

Calibration 14.A new operator rectangle 

appeared in our graph.

15.Connect the new operator with 

both the Remove-GRD-Border-

Noise and Write operators.

16.Save the workflow to 

S1_Preprocessing_1.xml

17.Close the Graph Builder window.
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Data Pre-processing
Calibration



1. In the Main Menu, 

open the Batch 

Processing tool 

(Tools → Batch 

Processing).

1

2. We will add both opened products by clicking Add Opened in the 

upper right (the second icon from the top) and then clicking Refresh

(the second icon from the bottom). 

2

Data Pre-processing
Batch processing 



3. In the Batch Processing

window, click File → Load Graph

and navigate to our saved graph 

(S1_Preprocessing_1.xml) and 

open it.

4. We see that new tabs have appeared at the top of the 

Batch Processing window corresponding to our 

operators. We will change the parameter of each 

operator in the next steps.

3

4

Data Pre-processing
Batch processing



6. In the ThermalNoiseRemoval tab select VV polarization 

and make sure that the “Remove Thermal Noise” option 

is selected.

5. In the Apply-Orbit-File tab, accept the default settings.

5 6

Data Pre-processing
Batch processing



8. In the Calibration tab, make sure the VV polarization is 

selected and select the ”Output beta0 band” option. The 

beta0 is required for another processing step (Terrain 

Flattening).

7. In the Remove-GRD-Border-Noise tab, make sure the 

VV polarization is selected and accept other default 

settings.

Data Pre-processing
Batch processing

7 8



9. In the Write tab, define your output name and directory.

10.Click Run. It will take a few seconds or minutes to complete the process. 

You should have 2 new products in the Product Explorer window. Close the Batch Processing window.

9

Data Pre-processing
Batch processing

10



1. In the Main Menu, go to 

Tools → GraphBuilder

2. First, we need to delete the Write operator. Right click on it and select “Delete”. Then we 

need to add a second Read operator. Right-click in the white space and go to Add → Input-

Output → Read.

3. We will add the SliceAssembly operator by going to Add → Radar → Coregistration → Add 

→ Radar → Sentinel-1 TOPS → SliceAssembly and connect both Read operators to it.

4. Next, we will add the Subset operator (Add → Raster → Geometric → Subset) and connect 

the SliceAssembly operator to it. 

5. Add the Speckle-Filter operator (Add → Radar → Speckle Filtering → Speckle-Filter) and 

connect the Subset operator to it.

6. (Optional) Add the Multilook operator (Add → Radar → SAR Utilities → Multilook) and 

connect the Subset operator to it.

7. Add the Terrain-Flattening operator (Add → Radar → Radiometric → Terrain-Flattening) 

and connect the Speckle-Filter operator to it.

8. Add the Terrain-Correction operator (Add → Radar → Geometric → Terrain Correction → 

Terrain-Correction) and connect the Terrain Flattening operator to it.

9. Lastly, we will add the Write operator (Add → Input-Output → Write) and connect the 

Terrain-Correction operator to it to save the final product

2

3 4 5 76

1

Data Pre-processing
Open Graph Builder again

8 9



9. First, let’s go to the first Read tab and make sure that the pre-processed product [3] from the first 

scene is selected as the Source product. Then go to the Read(2) tab and set the pre-processed 
product [4] from the second scene as the Source product.

Data Pre-processing
Read data

9



10. Go to the SliceAssembly tab and make sure the VV polarization is selected

Data Pre-processing
Slice assembly

• To avoid distributing huge unwieldy products to end users, the Sentinel-1 data are segmented into 'slices' of defined 

length along a track. Product slices make the data more manageable for users and enable the ground segment to 

process slice data in parallel.

• Sliced products may be seamlessly combined, including the metadata, into an assembled product. Product 

assembly follows specific rules for including, merging and concatenating the various components of the slice 

products. 

10



Since our Area of Interest (AOI) is less and there is no need to process the whole assembled image, we start with 

sub-setting the scene to a more manageable size. This will reduce the processing time in further steps and is 

recommended when the analysis is focused only on a specific area and not on the complete scene. 

11.Go to the Subset tab and at “Pixel Coordinates” set:

X         = 1000 Y         = 8000

Width  = 1000 Height  = 17000

Data Pre-processing
Subset image

11



Data Pre-processing
Speckle filter

12

• SAR images have inherent salt and pepper like texturing called speckles which degrade the quality of the 

image and make interpretation of features more difficult.

• Speckles are caused by random constructive and destructive interference of the de-phased but coherent return 

waves scattered by the elementary scatters within each resolution cell.

• Speckle noise reduction can be applied either by spatial filtering or multilook processing. The operator supports 

several speckle filters for handling speckle noise of different distributions (Gaussian, multiplicative or Gamma), 

including Boxcar (mean), Median, Frost, Lee, Refined Lee, Gamma-MAP, Lee Sigma, IDAN.

12. Go to the Speckle-Filter tab and select Refined Lee filter method. You can try other available 

filters if you’d like.



Data Pre-processing
(Optional) Multi-look

12

• Multi-look processing can also reduce the inherent speckled appearance, thus improving the image 

interpretability. It can be produced by space-domain averaging of a single look image or by frequency-domain 

method using the sub-spectral band width.

• Additionally, multi-look processing can be used to reduce the image pixel size.

12. Go to the Speckle-Filter tab and change the Number of Range Looks to 3.



• Terrain variations affect not only the position of a target on the Earth's surface, but also the brightness 

of the radar return. Without treatment, the radiometric biases caused by terrain variations are 
introduced into the coherency and covariance matrices.

• This operator removes the radiometric variability associated with topography using the Radiometric 
Terrain Correction algorithm. 

• In the RTC algorithm, the radiometric effect is simulated using a digital elevation model (DEM) of the 
imaged area. It is therefore required that the DEM resolution must be higher than the image 

resolution. In case that the DEM resolution is lower than the image resolution, users have two options: 
1) Oversample the DEM to higher resolution, 2) Multilook the source image to lower resolution

• The input to this operator should be calibrated beta0. The output of this operator is terrain flattened 
gamma0.

Data Pre-processing
Terrain flattening



Data Pre-processing
Terrain flattening

13

13. Go to the Terrain-Flattening tab and accept the default settings.



Data Pre-processing
Terrain correction

• Due to topographical variations of a 

scene and the tilt of the satellite 

sensor, distances can be distorted in 

the SAR images. 

• Image data not directly at the 

sensor’s Nadir location will have 

some distortion. 

• Terrain corrections are intended to 

compensate for these distortions so 

that the geometric representation of 

the image will be as close as 

possible to the real world.

14. Go to the Terrain-Correction tab. In the Digital Elevation 

Model, select SRTM 1Sec HGT (Auto Download).
15. In the Map Projection, select projection UTM/WGS 84 

(Automatic) and click OK.

15

15

14



16.Go to the Write tab and define your output directory.

17.Now that all settings are completed. Run the Graph Builder.

Data Pre-processing
Write output and Run the Graph Builder

16
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Data Pre-processing
Visualize the output



Data Pre-processing
Convert to decibel

1. In the Product Explored, 

open the output band 

folder, then right-click on 

the Gamma0_VV band.

2. Select Linear to/from dB.

Accept the pop-up window 

to confirm the conversion 

to a new virtual band.

1

2 3. The converted 

Gamma0_VV_db band will be 

saved on the band folder. 

4. Right-click on this new band, 

then select Convert Band to 

convert the virtual band to 

image.

5. Last, right-click on the [5]

folder, and select Save Product

3

4

5



Data Pre-processing
Visualize the new output



Data Pre-processing
Repeat the same processing workflow for Pre-flood images



Data Pre-processing
Defining a threshold value (1)

Next, we will separate water and non-water pixels. 

We have to define a threshold value in which we 

assume that the pixels whose values are below 

the threshold belong to the water area, and those 

that are above that threshold belong to the non-

water area. 

We can manually inspect the threshold value by 

visually checking the image.

1. In the Main Menu, go to View → Tool 

Windows → Pixel Info.

2. Hover over the image and check the value in 

the Pixel Info window

2



Data Pre-processing
Defining a threshold value (2)

We can also calculate a histogram to define the 

value. Ideally, a threshold can be defined when 

the histogram is a bimodal distribution containing 

two peaks separated by a valley.

1. In the Main Menu, go to Analysis →

Histogram. 

2. Click Refresh          to calculate the histogram

See that the distribution does not really look like a 

bimodal one. This is because the full image 

contains much larger non-water than water areas.

2



Data Pre-processing
Defining a threshold value (3)

Let’s create a group of polygons to get the 

distribution that balances water and non-water 

areas.

1. In the Main Menu, go to Vector → New vector 

Data Container. Give a name aoi to the new 

container and click OK.

2. Zoom in the Gamma0_VV_db image and 

create several polygons using the Drawing 

tools                        in the Tool Bars.

1

2



Data Pre-processing
Defining a threshold value (4)

Now, we calculate the histogram based on the aoi.

1. In the Main Menu, go to Analysis →

Histogram. 

2. Checklist the Use ROI mask.

3. Click Refresh          to calculate the histogram

We now have the bimodal distribution. Estimate 

the value for the valley that we can choose as our 

threshold to create the binary images for the water 

and non-water areas.

2

3

Threshold value



Data Processing in QGIS
Open QGIS Software

• Open QGIS Desktop in your 

laptop/PC: 

• You will have a new, blank map.

1. Menu Bar

2. Toolbars

3. Layers List / Browser Panel

4. Map View

5. Status Bar

1

2
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Data Processing in QGIS
Open the pre-processed Sentinel-1 data

1. In the Menu Bar, click on Layer → Add Layer 

→ Add Raster Layer.

2. In Data Source, click on the Browse button 

and navigate to the file 

\Subset_S1A_IW_GRDH_1SDV_20240915T

231601_20240915T231651_055682_06CCB

A_08DA_Orb_NR_Cal_Asm_Spk_ML_TF_T

C.data\Gamma0_VV_db.img in the data 

folder.

3. With this file selected, click Add, then Close. 

The data you specified will now load.

2

3



Data Processing in QGIS
Rename the raster image

The images name for post-flood and pre-flood 

images are identical. To avoid confusion, we will 

rename the image by including the date.

1. Right-click the raster image, then go to Layer 

Properties and switch to the Source

2. Rename to Gamma0_VV_dB_20240915.

3. Click OK.

2

3

1



Data Processing in QGIS
Creating a binary map bases on a threshold value

We will use this threshold value: -15 dB.

1. Click on Raster → Raster Calculator.

2. In the Raster Calculation Expression write:     

"Gamma0_VV_db_20240915@1" <  - 15

3. Save the result to water_20240915.tif

4. Click OK.

2

3

4



Data Processing in QGIS
Changing visualization color scheme

1. Go to Layer Properties and switch to the 

Symbology

2. Change Render type to Paletted/Unique 

values.

3. Click Classify. You will get two values, 0 and 1.

4. Make transparent color for value 1 by changing 

its opacity. Right-click color of value 1, then 

select Change Opacity. Write 0, then OK.

5. Click OK.

2
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Data Processing in QGIS
Visualization: Water pixels in the post-flood image



Data Processing in QGIS
Repeat the same process for the pre-flood image



Data Processing in QGIS
Estimating the flood pixels

We will estimate the flood pixels by subtracting 

water pixels from post-flood with the pre-flood.

1. Click on Raster → Raster Calculator.

2. In the Raster Calculation Expression write:     

"water_20240915@1" - "water_20230921@1"

3. Save the result to flood_20240915.tif

4. Click OK.
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Post-processing in QGIS
Installing a plugin: SAGA Next Gen

Plugins allow you to extend the functionality QGIS 
offers.

1. In the Menu Bar, click on Plugins → Manage 
and Install Plugins.

2. In the dialog that opens, find the Processing 
SAGA NextGen Provider plugin.

3. Click Install Plugin.

4. Click Close.

Your new plugin is installed. You will find the 
installed SAGA Next Gen in the processing 
toolbox.

2
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Post-processing in QGIS
Remove isolated pixels

1. In the Menu Bar, click on Processing → 
Toolbox.

2. Search for Majority/minority filter processing 
tool, then open the tool.

3. In the Grid input, select floods_20240915.

4. Change Kernel Type to Square and keep 
other parameters as default. You may want to 
test with different threshold and radius.

5. Save the result to 
floods_20240915_filtered.sdat

6. Click Run

3
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Post-processing in QGIS
Visualization: Comparing flood pixels before and after filtered



Post-processing in QGIS
Convert flood pixels to polygon

1. In the Menu Bar, click on Raster → 
Conversion → Polygonize (Raster to Vector).

2. In the Input layer, select 
floods_20240915_filtered.

3. Save the result to 
floods_20240915_filtered.shp

4. Click Run

2

3

4



We will select polygons with value of 1 by writing 
in the Expression box:  “DN"  =  1 

3. Expand the Field and Values and double-click 
DN. The text will be added to the Expression 
box. 

4. Click        and the text in the Expression box 
will be updated.

5. Click All Unique, then double-click 1.

6. Click Select Features

Post-processing in QGIS
Filter flood polygons from attribute

1. Right-click on the floods_20240915_filtered 
layer, then click Open Attribute Table

2. In the Table Toolbars, click Select features 
using an expression button.

3
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Post-processing in QGIS
Save selected flood polygons to a new shapefile

1. Right-click on the 

floods_20240915_filtered layer in the 
Layers list, click Export → Save 
Selected Features As…

2. Make sure to checklist “Save only 
selected features”.

3. Save the result to 
floods_20240915_filtered_DN1.shp.

4. Click OK.

2
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Post-processing in QGIS
Calculate the area of each polygon in the table

Calculate area of each polygon in the attribute 
table of floods_20240915_filtered_DN1.

1. Right-click on the layer, then click Open 
Attribute Table

2. In the Table Toolbars, click Open Field 
Calculator button.

3. In Output field name, write area.

4. In Output field type, select Decimal number 
(real).

5. Expand the Geometry and double-click $area. 
The text will be added to the Expression box. 

6. Click OK.

3

4

5

6
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Post-processing in QGIS
Calculate total flooded area

1. In the Menu Bar, click on Vector → 

Analysis Tools → Basic Statistics for 
Fields.

2. In the Input layer, select 
floods_20240915_filtered_DN1.

3. Select the field area to calculate 
statistics on.

4. In the output, the total flooded area is 
the value for SUM. The unit is square 
meters, so to get the area in square 

kilometers, you have to divide by 
1,000,000. 

2

3

4



Post-processing in QGIS
Visualization: Final flood map



THANK YOU
Geoinformatics Center, Asian Institute of Technology
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